Skip to end of metadata
Go to start of metadata

Applies to:

openSUSE Leap 42.2

Symptom:

Your Cryptshare appliance is running openSUSE 42.2 Leap and needs to be upgraded to 42.3 Leap. Additionally, you are running ClamAV on Version 0.99.2 that is affected by a security vulnerability discovered in January 2018.


Solution:

The solution is to upgrade from openSUSE 42.2 Leap to 42.3 Leap. This will also install the latest version of ClamAV.


Backup of the entire system

It is highly recommended to make a full backup of the server in order to be able to restore the state before the first upgrade steps were made.

To upgrade your OS to openSUSE 42.3 Leap as well as ClamAV to 0.99.3 or later, please proceed as follow:

  1. Log in as 'root' on your appliance

  2. Make sure to have a backup of your system before proceeding
  3. Start the upgrade process by executing the following command:

    curl http://update.cryptshare.com/cryptshare/scripts/upgrade_from_42.2_to_42.3.sh | sh
  4. Wait for the process to finish (you will get back to the command prompt) and verify the OS and ClamAV version with the following commands:

    cat /etc/os-release
    clamdscan -V
  5. If the output version is equal to or newer than the version illustrated below, the upgrade was successful:

    cryptshare:~ # cat /etc/os-release 
    NAME="openSUSE Leap"
    VERSION="42.3"
    ID=opensuse
    ID_LIKE="suse"
    VERSION_ID="42.3"
    PRETTY_NAME="openSUSE Leap 42.3"
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:opensuse:leap:42.3"
    BUG_REPORT_URL="https://bugs.opensuse.org"
    HOME_URL="https://www.opensuse.org/"
    
    cryptshare:~ # clamdscan -V
    ClamAV 0.99.3/24289/Tue Feb  6 02:27:45 2018
  6. reboot the appliance with the following command:

    cryptshare:~ # reboot